Follow

Current cannot process .deb packages created for because Ubuntu switched to zstd compression and dpkg in Debian does not support that 😱

Here is the main error when trying to install a binary .deb from a PPA:

dpkg-deb: error: archive '/var/cache/apt/archives/picosnitch_0.9.0+435-9462cb2~ubuntu22.04.1_amd64.d
eb' uses unknown compression for member 'control.tar.zst', giving up

It seems there is a bug against dpkg in Debian but work has stopped(!?):

bugs.debian.org/cgi-bin/bugrep

· · Web · 1 · 0 · 0

More concretly the switch seems to be between Ubuntu hirsute (21.04) and impish (21.10).

Trying the picosnitch PPA for hirsute release still works on Debian Bookworm, but the impish and jammy (22.04) targets fail....

Sign in to participate in the conversation
hostsharing.coop | Hostsharer im Fediverse

hostsharing.coop ist die Mastodon-Instanz für Mitglieder der Hostsharing eG. Sie wird seit 2018 von der Hosting-Genossenschaft betrieben.